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About This Tutorial

Forward:

I've noticed plenty of folks are wondering how to create ship icons for their mods. | was one of them.
After much research, trail, error, and frustration, I've finally gotten it down. Now I'll share it in complete
detail with everyone else.

| purposely made this tutorial very detailed so that absolutely anyone would be able to follow it.
Therefore, | beg forgiveness from the more artistically adept amongst you. Or, for that matter, the more
technically savvy.

| use Photoshop 7, so the explanations and images here reflect my preference in image editing software.
If yours is different, you should still be able to follow along.

Contact Information:

If you have any problems with or questions about this tutorial, you can contact me in the public forums at
my web site (www.tdfp.com) or those at The Lancers Reactor (www.lancersreactor.com). This is the
preferred way of working out any problems, since others with similar issues will benefit. Alternatively, you
can contact via e-mail by writing to: freelancer@tdfp.com .

Acknowledgements:

Special thanks go to all the participants of the Editing Forums on The Lancers Reactor. This would have
been impossible without you.


http://www.tdfp.com/
http://www.lancersreactor.com/
mailto:freelancer@tdfp.com

|. Making the lcon

Step 1: Make the ship element of your icon.
Tools needed: Photoshop or equivalent image editing software
A. Get a screenshot of your ship at the ship dealer's screen.

Arrange the movable 3D model of your ship till you have the angle you’re looking
for, then snap the shot (print screen button). You get the best shots if your screen
resolution is 1600 x 1200.

B. Open the screenshot up in photoshop and extract just the ship part of the image.
a. Select the Rectangle Marquee tool.

b. Click and drag to surround just enough of the image to get your ship
(see image 017).
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a. Select Edit=>Copy (Ctrl-C).



C. Start a new file that can be worked from.
a. Select File=>New (Ctri-N).

This will bring up a selection menu for a new file with the required
dimensions already filled in. Just make sure that Transparent is selected
in the Contents box (see image 02).
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b. Click OK in the new file box.
c. Make sure the new blank image is selected.
d. Select Edit=>Paste (Ctr/-V).

You now have a workable image of your ship (see image 03).
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You can close the original screenshot at this point as we won't be using it
again.

D. Getrid of everything except the ship itself.

a. Select the Magnification tool and magnify the image to a comfortable level
for you.

b. Select the Eraser tool and erase all of the purple background, leaving only
the ship. Be very precise. You should end up with an image like the one
depicted in /mage 04.

image 04

E. Save the image (in .psd format) just in case something happens. You've done a
lot of work already... don't lose it.

F. Make a new image that exactly contains your ship. This lets us know what size
the image is without having to worry about padding around the image.

a. Make sure the ship image is selected.

b. Select Select=>All (Cirl-A).

c. Select Edit=>Copy (Ctr/-C).

d. Select File=>New (Ctri-N).

e. Make sure Transparent is selected on New File dialog box.
f. Click OK on New File dialog box.

g. Make sure new blank image is selected.



h. Select Edit=>Paste (Ctr/-V). Your new image should contain your ship
image with the edges of the ship touching the edges of the image
(see image 05).
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i. Ifthere is extra space that shouldn't be there, you probably have a stray
purple pixel that you failed to erase from step D. Go back to that step and
fix it.

G. Save the image. You can close the previously saved image if you like.
H. Resize the image.

Ship icons are 64x64 Targa images. You'll want a little space between your ship
and the icon edge so the maximum dimension should be about 56 pixels.

a. Make sure your ship image is selected.

b. Select Image=Image Size. A dialog box should appear (see image 06).
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Make sure that both Constrain Proportions and Resample Image check
boxes are checked. Resample should be Bicubic.

Check your image width and height (make sure your measuring in pixels).

Change whichever is larger to 56. The other dimension should change to
something smaller than 56 (see image 07).
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Click OK. You now have an image of your ship that is scaled to fit in an
icon.

Pat yourself on the back and celebrate (but save this image first). You can
minimize your creation if you like. We'll get back to it later.



Step 2: Make the background element of your icon.
Tools needed. Photoshop, Freelancer UTF Edlitor

A. Get an existing icon so that you'll have a reference while making yours. We'll use
the Liberty Defender icon.

a. Start the Freelancer UTF Editor
b. Click the Open File button.

c. Navigate your way to the icon directory:

Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS

d. Select the file: li_elite.3db (see image 08).
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e. Click the Open button on the dialog.

f. Click the plus sign (+) in the space on the left side of the UTF editor to
expose the tree.

g. Click the plus sign (+) to the left of the Texture Library node.



h. Click the plus sign (+) to the left of the li_elite.tga node.

i. This exposes a leaf called MIP0O. Which is a targa (.tga) file.

Important Note

Freelancer uses two kinds of images that | am aware of:

e MIPO (with a zero), which are targa files.
e MIPS, which are Direct Draw (.dds - even though the leaf calls them .tga)*.

*They are actually MIP Maps and usually have several sizes of the same image in them in
order to handle the level of detail (LOD) dependent on the distance from which the object is
viewed. But that’s a different tutorial.

j- Click on the MIPO leaf (see image 09).
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k. Click the Export button.
Navigate to a directory of your choice.

It's best to NOT export to the icon directory. Try to keep the original game
directories unchanged lest anything truly unwanted happens to your game.
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| have a directory called Icontut that I'm using for this tutorial. We'll use
that for now.

m. Name the file anything you want just be sure to give it a .tga extension.
We'll use li_elite.tga just to keep everything neat (see image 10).
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n. Click the Save button.
0. Close the UTF Editor, we're done with it for now.
B. In Photoshop, create a new 64 pixel by 64 pixel image.
a. Select File=>New (Ctri-N).

b. Change width and height values to 64 and make sure resolution is set to
72 on New File dialog box (see image 1717).




e.

f.
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Click OK on New File dialog box.

Fill the image with a dark, not black color (I use color value 272727).
Select the Paint Bucket tool from toolbar.

Click on the image.

C. Open the targa image we extracted earlier (li_elite.tga) and position it close to
your icon background image so we can reference it.

a.

b.

Select File=>Open (Cirl-O).

Choose li_elite2.tga from directory where it was saved.

D. Change back to our work in progress by clicking on it. Now we will add that
highlight effect that most Freelancer icons have.

a.

b.

Select Filter=>Render=Lighting Effects.
Make sure style is Default and light type is Spotlight.
Adjust the intensity to between 65 and 75. We'll use 75.

Expand the spotlight arc to nearly touch each side of the panel and direct
the light to come from directly above.

Move the focal point (center) of the light to approximately halfway between
the bottom of the image and the bottom of the panel (see image 12).
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f. Adjust the arc, focal point, and intensity until you feel you have closely
replicated the reference image. Move panels around if you need to so you
can see the Defender icon while you are making adjustments.

g. Click OK when you are satisfied.
E. Save the image.

Name it whatever you like, just remember that you'll be able to use this over and
over for your custom icons, so don't name it something you'll forget. @
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Step 3: Combine the ship and background

This is pretty easy and should only take a few steps to explain. Make sure you have the
following files you made earlier open (see image 13).
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e The 64x64 pixel .psd file with your background image
e The small ((?? x 56) or (56 x ??)).psd file with your ship image
e The example icon we extracted earlier

A. Copy the ship image onto the background as a new layer.
a. With the ship image being the active image, select Select=>All (Ctrl-A).
b. Copy the image by selecting Edit=>Copy (Ctr/-C).

c. Make the background image the active image
(just click on the title area of the image).

d. Paste the ship image by selecting Edit=Paste (Cir/-V).
Notice that the ship image was applied to the background as a new layer.

This is important because we can continue pasting different ships onto this
background and each will have it's own layer.
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Then, by hiding all layers except the background image and the ship with
which we happen to be working on at the time, we can make a lot of icons
from one image file.

Click the little eye in Layer box on the right to hide or reveal layers.

. Move the ship around on the background if needed using the Move tool
from the toolbar.

Normally you won't have to do this, since the pasting process places the
image dead center of the applied image. But you may want to adjust it
some depending on the shape of the ship.

Just make sure you have the ship layer selected before you start moving
things about.

If you slip up, always remember the

Edit=>Undo (Cir/-2)
or
Edit=>Step Backward (Ctrl-Alt-2)

to step back through multiple undos
(my favorite combination, since | use it a lot). &2
Save the image as a .psd file.

Use a name something like master_icons.psd or the like. That way you'll
always know this is the image you'll create your icons from.

. Now, save it again as a .tga (Targa) file.

(with just the background and a single ship layer revealed if you've jumped
ahead and added more ships already)

This will be the targa image we will use for our in-game icon. Name it
something simple but descriptive.

We'll use li_elite2.tga for our example (see image 14).
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Photoshop will moan about the fact that the image must be saved as a
copy. That's OK. Just name it and save it.

A Targa Options dialog will appear. | normally choose 24 bits/pixel.
Important: Make sure that the Compress (RLE) option is NOT checked.

You should end up with a Targa image that looks something like /mage 75.

image 15

Congratulations! You now have an icon image that is both suitable and compliant for
use in the Freelancer game.
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ll. A Side Trip

The Good, the Bad, and the Ugly aspects of Freelancer icons

| want to take the time while doing this tutorial to explain (to the best that | understand it)
how icons are implemented in Freelancer. The more you understand, the easier it is for
you to decide how to implement your own icons.

Much of what is about to be presented is due to the extensive work of Mario "HCI" Brito
and Reven. | would be remiss if | didn't mention them at this juncture.

First, some analysis. As you are already aware, Freelancer get the information for the
ship icons from a .3db file located in the
Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN ICONS directory.

The .3db files are named for the ships which they represent (i.e. li_elite.3db for the

Defender). If you look at any icon .3db file in the UTF editor, you'll notice five nodes
(VMeshLibrary, VMeshPart, VMeshWire, Material library, and Texture library). Let's
break these down a little further:

The Ugly
VMeshLibary

Contains yet another node that is named consistent with the path to the icon file
followed by what appears to be a specific VMesh. In the case of li_elite.3db this is:

data.equipment.models.commodities.nn_icons.li_elite.lod0-112.vms
The sub-node has a data leaf called:
VMeshData

This data looks in a hex editor like this:

00000000h: 01 00O OO OO 04 00 00 00 01 00 06 00 12 01 04 0O
00000010h: 8A 15 93 07 00 00 03 00 06 00 cC 00 00 00 01 OO
00000020h: 02 00 01 00 03 00 02 00 93 80 11 3D 67 8F 0B BD
00000030h: DA 5A CD B3 6B 64 E8 29 41 29 01 B2 00 00 80 3F
00000040h: 40 DF 7F 3F 00 F2 02 3A 93 80 11 3D 6F 8F 0B 3D
00000050h: 34 41 CC B3 6B 64 E8 29 41 29 01 B2 00 00 80 3F
00000060h: 44 DF 7F 3F 41 DF 7F 3F 98 80 11 BD 67 8F 0B BD
00000070h: DA 5A CD B3 6B 64 E8 29 41 29 01 B2 00 00 80 3F
00000080h: 00 F2 02 3A 00 08 03 3A 98 80 11 BD 6B 8F 0B 3D
00000090h: 32 41 CC B3 6B 64 E8 29 41 29 01 B2 00 00 80 3F
000000a0h: 00 FE 02 3A 44 DF 7F 3F

That's 168 bytes of data contained in VMeshData. This example uses the li_elite.3db.
Other files will have slightly different information. The data can be further broken down
into it’s fields (for lack of a better term) using research documented by HCI and Dizzy:
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Entries key to our analysis are highlighted in yellow.

Header (16 bytes):

dword 01
dword 04
word 01
word 06
word 12
word 04

00 00 00 =
00 00 00 =

00
00
01
00

Ox1
0x4
Ox1
0x6
0x112
0x4

SN oY P

Mesh Segment (12 bytes):
0x793158A =

dword
word
word
word
word

8A
00
03
06
cC

Triangle
word 00
word 01
word 02

Triangle
word 01
word 03
word 02

Vertex 0
float 93
float 67
float DA
float 6B
float 41
float 00
float 40
float 00

Vertex 1
float 93
float 6F
float 34
float 6B
float 41
float 00
float 44
float 41

Vertex 2
float 98
float 67
float DA
float 6B
float 41
float 00
float 00
float 00

15 93 07
00
00
00
00

0x0
0x3
0x6
0xCC

1 Segment (6 bytes):
= 0x0

00
00
00

Ox1
0x2

2 Segment (6 bytes):

00
00
00

Ox1
0x3
0x2

Segment (32 bytes):

11
OB
CD
E8
01
80
TF
02

80
8F
5A
64
29
00
DF
F2

3D
BD
B3
29
B2
3F
3F
3A

0x3D11809
0xBDOB8F6

3
5

0xB3CD5ADA

0x29E8646
0xB201294
0x3F80000
0x3F7FDF4
0x3A02F20

Segment (32 bytes):

11
OB
CcC
E8
01
80
TF
TF

80
8F
41
64
29
00
DF
DF

3D
3D
B3
29
B2
3F
3F
3F

Segment (

11
0B
CD
E8
01
80
02
03

80
8F
5A
64
29
00
F2
08

BD
BD
B3
29
B2
3F
3A
3A

32

0x3D11809
0x3DOB8F6
0xB3CC413
0x29E8646
0xB201294
0x3F80000
0x3F7FDF4
0x3F7FDF4

bytes):
0xBD11809
0xBDOBS8F6

B;
1;
0;
0;
0;

3 =

F

4

B;
1;
0;
4;
1;

; All VMeshData in icon
; All VMeshData in icon

.3db files have this
.3db files have this

; Number of meshes
; Total number of referenced vertices

; FVE field

(I have no idea what it's for)

; Total number of actual vertices

127079818

0.03552300856
-0.03407230601 ;

’

materialID after CRC32 calulation
Start vertex

End vertex

Number of referenced vertices
Padding??

=

vertex
vertex
vertex 3

N

vertex 1
vertex
vertex

N

; X

Yy

-0.00000009562582193 ; =z

normal x
normal y
normal z
u
v

0.03552300856 ;
0.03407233581;

X
Yy

= -0.0000000951135064; =z

8 =

7

0xB3CD5ADA

0x29E8646
0xB201294
0x3F80000
0x3A02F20
0x3A03080

B;
1;
0;
0;
0;

normal x
normal y
normal z
u
v

-0.03552302718;
-0.03407230601;

X
Yy

= -0.00000009562582193; =z

normal x
normal y
normal z
u
v

18



Vertex 3 Segment (32 bytes):

float 98 80 11 BD = 0xBD118098 -0.03552302718; x

float 6B 8F 0B 3D = 0x3DOB8F6B = 0.03407232091; vy

float 32 41 CC B3 0xB3CC4132 = -0.00000009511349219; =z
float 6B 64 E8 29 0x29E8646B; normal x

float 41 29 01 B2 0xB2012941; normal y

float 00 00 80 3F = 0x3F800000; normal z

float 00 FE 02 3A = 0x3A02FE00; u

float 44 DF 7F 3F = O0x3F7FDF44; v

Feel free to convert out the remaining floats if you like (my head hurts). They are not
significant to the point I'm trying to make.

If we plot out the vertices and connect them as the VMeshData defines, we end up with
a square plane (see image 16).

image 16

Why map out a plane for an icon? | have no idea. Unless they needed something to
apply a material to. After some thought, I'm gonna have to jump on Reven's side and
quit asking why when it concerns Microsoft. But the significance is the fact that it is not
significant. Every icon VMeshData defines a square plane. So the node name
"data.equipment.models.commodities.nn_icons.li_elite.lod0-112.vms" has no apparent
connection to the actual data. That /s important because it means we can change it.
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Also of importance is the materiallD, that number is literally the string "SHIP_Ili_elite"
after going through the modified CRC calculation. I'm liking this already.

Let's move on...

VmeshPart

Contains a data leaf called VMeshRef. This data looks in a hex editor like this:
00000000h: 3C 00 00 00 6B 99 A8 OE 00 00 04 00 00 00 06 00
00000010h: 00 00 01 00 93 80 11 3D 98 80 11 BD 6F 8F 0B 3D

00000020h: 67 8F OB BD 32 41 CC B3 DA 5A CD B3 71 A8 2E 3A
00000030h: 63 5E 3D BB F8 D9 CC B3 53 E1 53 3D

That's 60 bytes of data contained in VMeshRef. Again, this example uses the
li_elite.3db, other files will have slightly different information. Breaking it out:

Again, entries key to our analysis are highlighted in yellow.

VMesh Segment (20 bytes)

dword 3C 00 00 00 = 0x0000003C = 60 ; They all start this way.

dword 6B 99 A8 OE = Ox0EA8996B = 245930347 ; VMeshID after CRC32 calculation
word 00 00 = 0x0000 =0 ; Start vertex

word 04 00 = 0x0004 = 4 ; End vertex

word 00 00 = 0x0000 =0 ; Start verex reference

word 06 00 = 0x0006 = 6 ; End vertex reference

word 00 00 = 0x0000 =0 ; Mesh number

word 01 00 = 0x0001 =1 ; Number of meshes

Array of floats (24 bytes) I think I've got this part right, let me know otherwise.

float 93 80 11 3D ; bounding box (min x)
float 98 80 11 BD ; bounding box (max x)
float 6F 8F 0B 3D ; bounding box (min y)
float 67 8F OB BD ; bounding box (max vy)
float 32 41 CC B3 ; bounding box (min z)
float DA 5A CD B3 ; bounding box (max z)

Array of floats (16 bytes)

float 71 A8 2E 3A ; Unknown
float 63 5E 3D BB ; Unknown
float F8 D9 CC B3 ; Unknown
float 53 E1 53 3D ; Unknown

Nothing super interesting going on here. The VMeshlID is important though. Itis the
string "data.equipment.models.commodities.nn_icons.li_elite.lod0-112.vms" after having
gone through the modified CRC32 calculation. Ah hah!

I'm going to skip VMeshWire because it isn't pertinent to solving our problem.
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The Bad
Material library
As always, entries key to our problem are highlighted in yellow.
Contains a direct data leaf called Material count. This data is in hex:
01 00 00 00 = 0x00000001 = 1 ; Only one material is used to make icon.
Contains a node called (in our case):

SHIP 1li elite; That should sound familiar. Changes with each icon.

This node (SHIP_Ili_elite) has three data leafs:

Type
string "DeDt" ; 27
DtName
string "1li_elite.tga" ; The filename of the icon
Dt flags
dword 40 00 00 00 = 0x00000040 = 64 ; Pixel size maybe?
dword 00 00 00 00 = 0x00000000 = Q0 ; 27

OK, we have a few more things we can modify.

Lastly,
Texture library

Contains a single sub-node named (in our case):

1i elite.tga ; As you've probably deduced, changes with each icon.

This sub-node has a data leaf called:

MIPO ; The actual image file named by the sub-node.
So, in this case, the actual bits that make up li elite.tga.

And that's all there is to the icon .3db file.
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The Good

OK, we know quite bit about .3db files now. But before you make your custom .3db file,
you're going to have to decide how you to tackle it. Basically, you have three options:

Option 1: Import the icon image into a copy of a .3db file for a pre-existing ship,
making minimal changes to the data in the .3db file with the UTF editor.

Pros: Easy to do (in fact this is probably what a lot of people do).

Cons: Undesired image displayed when you visit a ship dealer that sells the ship
that you used to copy the .3db file.

Details: | brought Juni's ship into my mod (the Defender with the tall tail). | called
it the Guardian. | used option 1 to make my icon. | used a copy of the Starblazer
icon file to make my icon. When at Norfolk Shipyard where only Defenders and
Guardians are sold, everything looks fine (see image 17).

image 17

But, when | go to Manhattan, where the Starblazer is sold, my ship takes on the
persona of the icon file | copied to make it (see image 18).

image 18

| think the reason this happens (and this is just an educated guess) is because
the VMeshlID in my copied icon file still refers to the VMeshData under the node
"data.equipment.models.commodities.nn_icons.cv_starblazer.lod0-112.vms"
which, in turn, refers to the materiallD "SHIP_cv_starblazer". Since that
reference is already used at Manhattan, it has no need to look it up again and just
uses what it has already loaded in memory for that icon file.

If you are adding new ships and removing old ships, this option shouldn't cause
you any problems as long as you use icon files from the ships you are removing.
Likewise, if you are going to make your new ships available only at places where
someone in the copied icon ship is unlikely to get to for whatever reason, it
should be OK too. Finally, if you just aren't that hung up on aesthetics, this is
probably for you.
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Option 2: Import the icon image into a copy of a .3db file for an icon that is not used
in the game anyway, making minimal changes to the data in the .3db file
with the UTF editor.

Pros: Easy to do (not sure if many people actually know about this option).

Cons: Uses up icons you might be wishing to implement if you are including
extended equipment sales or additional commodities.

Details: There are several .3db icon files that (to the best of my knowledge) are
never used in the game. Perhaps they were meant to be implemented but for
whatever reason were dropped. At any rate, they are there and you could use
copies of them to make your ship icons. Since they aren't used, you are unlikely
to run across the anomaly of option 1. They are all located in the same
NN_ICONS directory with the ship icons. Some of these icons are listed below:
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contraband.3db

ﬁi_

equipicon_

missilelauncheri.3db

equipicon_

equipicon_guni.3db

S

electronics.3db

P ]
o
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&

equipicon_

missilelauncherii.3db

&

equipicon_

equipicon_gunii.3db

&

equipicon_armor.3db

]
1
=l

equipicon_guniii.3db

¥

equipicon_

missilelauncheriii.3db

®

equipicon_

£

equipicon_gun.3db

equipicon_
missilelauncheriv.3db

fe

equipicon_

weaponupgrade.3db

nomadpower.3db

powerplant.3db shieldgenerator.3db

There are others. Sniff around the directory and you'll see.

If you don't need these icons, then this is probably a good option for you. In my opinion,
it's a least better than option 1. But, if you are going to use these icons, I'm guessing
you can expect some strange results when you go to a ship dealer where the equipment
dealer sells an item that uses your copied icon. But, that's just a theory, | haven't tried it
yet.
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Option 3: Import the icon image into a copy of a .3db file for a pre-existing ship,
making important changes to the .3db file with the UTF editor.

Pros: Definitely no problems with duplicating images based on copied
icon file because you alter the file enough to make it an original.

Cons: Slightly more difficult to implement.
Easy to screw up if you are not careful.

Details: This is what | was desperately trying to do, but couldn't find any
tutorials or information on how to do it. To me, the ability to create an
original icon was paramount because | didn't want to ever face the
anomaly in option 1 and | may be using the icons from option 2 in my mod.
| needed a better answer. Now that I've figured it out, I'm going to share it
with everyone. | hope you think it was worth the effort.

24



[ll. Implementing the Icon

Implementing Option 1
Tools needed: Freelancer UTF Editor

This is pretty straightforward. Nonetheless, read carefully. There are a few places
where you can dork it up.

This step-by-step assumes a few things:
+ You've already created your icon image and saved it as a Targa (.tga) file.
+ You have a directory created to work in (don't work in game directories).
A. Get a copy of an icon file to work on

a. Navigate to the
Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS directory.

b. Select an icon file of your choice (We'll use li_elite.3db for the tutorial).
c. Select Edit=>Copy (Ctr/-C).
d. Navigate to your working directory.
e. Select Edit=>Paste (Ctr/-V).
B. Rename the file to reflect your new ship
a. Select the copied file.
b. Select File=>Rename (or click on the filename).
c. Rename the file (We'll use li_elite2.3db for the tutorial).
C. Import your icon image
a. Start up the UTF Editor.
b. Click the Open File button.
c. Navigate to your working directory and select the newly renamed file.
d. Click the Open button.
e. Expand the root node by pressing the plus sign (+) in the left pane.

f. Expand the Texture library node by pressing the plus sign (+)to the left of
the node name.
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g. Expand the sub-node (named li_elite.tga in our example)in the same
fashion.

h. Click on the data leaf called MIPO, it should be highlighted (see image 79).

&FI‘EELEI‘IEEI‘ UTF editor : X
=5
[+ WheshLibrary ~Tree...
E=porter Yersion M treel . | Delete Nu:u:le[si
- Wk eshPart

- Wi eshivfine

-- M aterial library — Currently selected...
= Testure library |
=1 li_elte.tga AsCll: |
Ll Hex: [DD1 01 00 00 00 01 18 00 09

Size: |4gg4 butes
— Interpret data az...

Feature of limited use.
Edit zimple data structures anly.

— Import / export data from file

Irpart. . | Export... |

Openfie.]  Savefie. | Edt |

image 19
i. Click the Import button.
j- Navigate (if necessary) to the directory where your icon image is located.

k. Select your icon image (the .tga version, we have li_elite2.tga for the
tutorial).

I. Click the Open button on the dialog.

Important: All we have done is replace the icon image. DO NOT edit
anything else with the UTF Editor. Doing so will cause various and
certainly unwanted effects when you enter a ship dealer's shop.

D. Save the file.
a. Click the Save File button.
b. Select the file that you renamed.

c. When asked if you want to replace the file, click Yes.
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E. Edit the GOODS.INI file to reflect your changes

Example:

[Good]

nickname = le2 hull
category = shiphull

ship = 1i elite2

price = 520000

ids name = 12003

item icon = Equipment\models\commodities\nn_icons\li_elite2.3db

F. Copy the file to the Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS
directory.

That's all there is to it. But remember, if you visit a ship dealer that sells the ship that
you "borrowed" the icon file from, your ship image will change to that ship.
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Implementing Option 2

Tools needed: Freelancer UTF Editor

Again, pretty straightforward. Nonetheless, read and follow carefully.

This step-by-step assumes a few things:

4
=

You've already created your icon image and saved it as a Targa (.tga) file.

+ You have a directory created to work in (don't work in game directories).

A. Get a copy of an icon file to work on

a.

d.

e.

Navigate to the
Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS directory.

Select an icon file of your choice (We'll use
equipmenticon_nomadpower.3db for the tutorial).

Select Edit=>Copy (Ctr/-C).
Navigate to your working directory.

Select Edit=>Paste (Ctr/-V).

B. Rename the file to reflect your new ship

a.
b.

C.

Select the copied file.
Select File=>Rename (or click on the filename).

Rename the file (We'll use li_elite2.3db for the tutorial).

C. Import your icon image

a.

b.

Start up the UTF Editor.

Click the Open File button.

Navigate to your working directory and select the newly renamed file.
Click the Open button.

Expand the root node by pressing the plus sign (+) in the left pane.

Expand the Texture library node by pressing the plus sign (+)to the left of
the node name.

Expand the sub-node (named li_elite.tga in our example)in the same
fashion.
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h. Click on the data leaf called MIPQO, it should be highlighted (see image 20).
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=]+ nomadpowersaurce. bga

i | P'D Hew: |nn 01 01 00000007 180000

Size: |4gg4 butes
— Interpret data az...

Feature of limited use.
Edit zimple data structures anly.

Hew treel Add node | Delete Nu:u:le[si

ASCII: |

— Import / export data from file——

Irpart. . | Export... |

Openfie.]  Savefie. | Edt |

image 20

i. Click the Import button.

j- Navigate (if necessary) to the directory where your icon image is located.

k. Select your icon image (the .tga version, we have li_elite2.tga for the
tutorial).

I. Click the Open button on the dialog.
Important: All we have done is replace the icon image. DO NOT edit

anything else with the UTF Editor. Doing so will cause various and
certainly unwanted effects when you enter a ship dealer's shop.

D. Save the file.
a. Click the Save File button.
b. Select the file that you renamed.

c. When asked if you want to replace the file, click Yes.
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E. Edit the GOODS.INI file to reflect your changes

Example:

[Good]

nickname = le2 hull
category = shiphull

ship = 1i elite2

price = 520000

ids name = 12003

item icon = Equipment\models\commodities\nn_icons\li_elite2.3db

F. Copy the file to the Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS
directory.

That's all there is to it. At least you won’t have the ship problem to deal with.
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Implementing Option 3
Tools needed: Freelancer UTF Editor, Freelancer CRC Calculator

FYI: The Freelancer CRC Calculator is an excellent tool developed by Reven.
Calculating the CRC values would be extremely difficult and time consuming without it.
Tell him thanks next time you get an opportunity.

This is a little more tricky. Read and follow very carefully. Any spelling errors,
misplaced entries, etc. and it's hosed.

This step-by-step assumes a few things:
+ You've already created your icon image and saved it as a Targa (.tga) file.

+ You have a directory created to work in (don't work in game directories).

A. Get a copy of an icon file to work on

a. Navigate to the
Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS directory.

b. Select an icon file of your choice (We'll use li_elite.3db for the tutorial).
c. Select Edit=>Copy (Ctr/-C).
d. Navigate to your working directory.
e. Select Edit=>Paste (Ctr/-V).
B. Rename the file to reflect your new ship
a. Select the copied file.
b. Select File=Rename (or click on the filename).
c. Rename the file (We'll use li_elite2.3db for the tutorial).
C. Import your icon image
a. Start up the UTF Editor.
b. Click the Open File button.
c. Navigate to your working directory and select the newly renamed file.
d. Click the Open button.

e. Expand the root node by pressing the plus sign (+) in the left pane.
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f. Expand the Texture library node by pressing the plus sign (+)to the left of
the node name.

g. Expand the sub-node (named li_elite.tga in our example)in the same
fashion.

h. Click on the data leaf called MIPQO, it should be highlighted (see image 21).
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Size: |4334 butes
— Interpret data az...
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Impaoit.... | Export... |

Openfie.]  Savefie. | Edt |

image 21
i. Click the Import button.
j- Navigate (if necessary) to the directory where your icon image is located.

k. Select your icon image (the .tga version, we have li_elite2.tga for the
tutorial).

I. Click the Open button on the dialog.
D. Rename the sub-node to the name of your icon image.
a. Click on the sub-node name (li_elite.tga in our tutorial).
b. Click on it once more so that you can edit the name.
c. Rename the node to reflect the name of your icon image (li_elite2.tga for

our example) (see image 22).
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image 22

d. Click elsewhere to affect the change.

E. Choose your new VMeshID and materiallD

a. In a text editor, type out what you would like to use for a new VMeshiD.

Helpful Hint
Stay with the naming convention used for other icon files just to be on the
safe side. The VMeshID for the Defender is:
data.equipment.models.commaodities.nn_icons.li_elite.lod0-112.vms
and something along these lines will be fine. For our tutorial, we'll use:
data.equipment.models.commodities.nn_icons.li_elite2.vms
for our new VMeshlID. It's shorter, but that's no problem.

b. In a text editor, type out what you would like to use for a new materiallD.

Helpful Hint
Again, it's best to stay with the naming convention used. The materiallD
for the Defender is SHIP_Ili_elite and something like that will work great.

WARNING: Do not use the name of the icon image. The sub-node name,
VMeshlID, and materiallD need to be unique.

For our tutorial, well use SHIP_li_elite2 for our new materiallD.
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F. Get the modified CRC32 calculated equivalents for the VMeshID and materiallD.

a.

b.

Start up the Freelancer CRC Calculator

Copy and paste the new VMeshlID into the CRC Calculator
(see image 23).

## Freelancer CRC Calc ! =100 x|

Idmaﬁqmpmentded&cumdeMe&nn_tnnsﬁ_eﬂezvmd

Text: 003293170 53091773
Clipboard: 0403238170 53061773

image 23

Note the humbers to the right of the Text: field. There is a hexadecimal
and a decimal number there. Copy the decimal number down and type it
under your VMeshlID so that you'll remember that the two are associated.

Copy and paste your new materiallD into the CRC Calculator
(see image 24).

i+ Freelancer CR =10l x|

|SHIF'_Ii_eIiteE

Text: 0=EDBF472E 3338735782
Clipboard:  O<EDBF472E 3988735782

image 24

Note the humbers to the right of the Text: field. There is a hexadecimal
and a decimal number there. Copy the decimal number down and type it
under your materiallD so that you'll remember that the two are associated.

You should have recorded in your text editor, something like the following:
New VMeshID
data.equipment.models.commodities.nn icons.li elite2.vms

53051773

New materiallD

SHIP 1i elite2
3988735782

You can close the CRC Calculator at this point. We are finished with it.
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G. Change the name of the VMeshLibrary sub-node.

a.

In the UTF Editor, open the VMeshLibrary node by clicking on the plus
sign (+) next to the node name.

Highlight your new VMeshlID from your text editor and copy it.

Select the sub-node name located under the VMeshLibrary node by
clicking it.

Click it once more so you can edit it (all the text will become highlighted).

Paste your new VMeshlD to replace it (Cir/-V) (see image 25).
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— Interpret data as...
TR e |
Feature of limited uze.
Edit zimple data structures anly.
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Irport.... | Export... |
1| | _}I Open fiIe...I Save file...l E =it |

image 25

H. Change the materiallD reference in the VMeshData Mesh segment.

g.

Highlight the decimal number associated with your new materiallD in your
text editor and copy it.

In the UTF Editor, change the interpret data as selector to int array.

Expand the sub-node you just changed the name of by clicking the plus
sign (+) next to the node name.

Select the data leaf named VMeshData.
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k. Click the Edit button.

At this point, a new window will pop up with several integer values. We
are interested in the fifth number down from the top (see image 26).

£z FrecLancer UIEE R x|
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|lpdate I Cancel |

[ C O ST Oate S s TS Oy

Import & export data from file
|V Irnpart... | Export... |
‘| | | Openfie.]|  Savefie.| Exit |
image 26

I. Replace the integer on the fifth line with the integer associated with your
new materiallD.

m. Click the Update button.
|.  Change the name of the Material library sub-node.

a. Inthe UTF Editor, open the Material library node by clicking on the plus
sign (+) next to the node name.

b. Highlight your new materiallD from your text editor and copy it.

c. Select the sub-node name located under the Material library node by
clicking it.

d. Click it once more so you can edit it (all the text will become highlighted).

e. Paste your new materiallD to replace it (Cirl-V) (see image 27).
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image 27

J. Change the name in Dt_name field to match your icon image.

a. Inthe UTF Editor, change the interpret data as selector to string.

b. Expand the Material library sub-node that you just modified.

c. Select the data leaf named Dt_name.

d. Click the Edit button.

At this point, a new window will pop up with the old filename of the icon

image.

e. Replace the filename with the correct one for your icon image... spelling

counts (see image 28).

37



f.
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image 28

Click the Update button.

K. Change the VMeshID reference in the VMeshRef data chunk.

a.

Highlight the decimal number associated with your new VMeshlID in your
text editor and copy it.

In the UTF Editor, change the interpret data as selector to int array.

Expand the VMeshPart node by clicking the plus sign (+) next to the node
name.

Select the data leaf named VMeshRef.
Click the Edit button.

At this point, a new window will pop up with several integer values. We
are interested in the second number down from the top (see image 29).
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f. Replace the integer on the second line with the integer associated with
your new VMeshID.

g. Click the Update button.

L. Save the file.
a. Click the Save File button.
b. Select the file that you renamed.
c. When asked if you want to replace the file, click Yes.
M. Edit the GOODS.INI file to reflect your changes
Example:
[Good]
nickname = le2 hull
category = shiphull
ship = 1i elite2
price = 520000

ids name = 12003
item icon = Equipment\models\commodities\nn_icons\li_elite2.3db
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N. Copy the file to the Freelancer/DATA/EQUIPMENT/MODELS/COMMODITIES/NN_ICONS
directory.

Badaboom badabing. You are now the proud owner of your very own custom ship icon.
Doesn't it feel great?

If you have any problems with this tutorial:
+ Check your spelling on everything.
# Double check the CRC values and entries.
+ Walk back through the tutorial step-by-step.

+ If you still have problems, drop me a note. I'll probably need your .cmp file in
order to determine if the problem is there or not.

| hope this tutorial helps somebody out there who needs it. After all the help I've gotten
from other tutorials and posts, | finally found a way | could give something back.
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